Northflank - Let's Encrypt Certificate Generation Issues – Incident details

All systems operational

Let's Encrypt Certificate Generation Issues

Resolved
Degraded performance
Started 6 days agoLasted about 5 hours

Affected

Northflank Platform

Degraded performance from 6:55 PM to 11:36 PM

Certificates

Degraded performance from 6:55 PM to 11:36 PM

Updates
  • Resolved
    Resolved

    No more certificate creation errors have been observed from Let's Encrypt. This incident has been resolved.

  • Monitoring
    Monitoring

    No recent API errors experienced and addon provisioning is working as expected. We're still closely monitoring Let's Encrypt API responses.

  • Investigating
    Investigating

    We are currently observing delays in certificate generation due to an ongoing incident with Let's Encrypt: https://letsencrypt.status.io/

    This will affect provisioning of new addons with TLS enabled, the provisioning of BYOC clusters as well as domain certification provisioning.